aports

Custom Alpine Linux aports

git clone https://git.8pit.net/aports.git

 1# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
 2# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
 3pkgname=creek-status
 4pkgver=20190721
 5pkgrel=1
 6pkgdesc="A status bar tool for the creek status bar"
 7url="https://github.com/nmeum/dwm-status"
 8arch="all"
 9license="WTFPL"
10makedepends="tinyalsa-dev"
11options="!check" # no test suite
12source="$pkgname-$pkgver.tar.gz::https://github.com/nmeum/dwm-status/archive/$pkgver.tar.gz
13	0001-Compile-without-X11-print-text-to-standard-output.patch
14	config.h"
15builddir="$srcdir"/dwm-status-$pkgver
16
17prepare() {
18	default_prepare
19	cp "$srcdir"/config.h "$builddir"/config.h
20}
21
22build() {
23	make
24}
25
26package() {
27	install -Dm755 "$builddir"/dwm-status \
28		"$pkgdir"/usr/bin/creek-status
29}
30
31sha512sums="
323171dfd1595b9d3ee167b1c123e7fc0ca5d293518d9389de906b1525f803e454436f4e466b4cba300f4e0ae0d44fc64294d5c1431189877d257ff4c2b4e350ee  creek-status-20190721.tar.gz
3332dc850895d73dc2f721f3b35e27f9f100055fd1ec0fb35cd20277e7c1aba72c8691a63da98c72c9827a14d94750e62d6aad3c264d717c57cb02f85eeff2ec4d  0001-Compile-without-X11-print-text-to-standard-output.patch
347a251419f1f835a9e647c4a8d43f89ff572cb3109b55a22e2ec6d45c24fd5fe3d6b6c868ac32e689bd413a2b3ec74e216594e83a7003d756b8e13a6bb6c270a9  config.h
35"