aports

Custom Alpine Linux aports

git clone https://git.8pit.net/aports.git

 1# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
 2# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
 3pkgname=loksh
 4pkgver=7.7
 5pkgrel=1
 6pkgdesc="A Linux port of OpenBSD's ksh"
 7url="https://github.com/dimkr/$pkgname"
 8arch="all"
 9license="Public-Domain"
10makedepends="ncurses-dev meson"
11install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
12options="!check" # upstream doesn't have a test suite
13subpackages="$pkgname-doc"
14source="loksh-$pkgver.tar.xz::https://github.com/dimkr/loksh/releases/download/$pkgver/loksh-$pkgver.tar.xz
15	bracketed-paste-mode.patch"
16
17build() {
18	abuild-meson \
19		--prefix=/ \
20		--bindir=/bin \
21		. output
22	meson compile -C output
23}
24
25package() {
26	DESTDIR="$pkgdir" meson install --no-rebuild -C output
27}
28
29sha512sums="
30002e3099a16052517f679f891293387dd55497aceedb5e959f2ae46fc3339b21856e48e402d7fcbffa1a17f1f9c6f433c32622284bd723293a02efe11dc755b9  loksh-7.7.tar.xz
31c276ad6c6815da3242f955dbe9702d90bdf8c186ce9e57c0945505b3939658c267c14649cdd2fcbabbd4ff9b1cada6dbadf985c94caf263ea2975db8366cbcca  bracketed-paste-mode.patch
32"