aports

Custom Alpine Linux aports

git clone https://git.8pit.net/aports.git

 1# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
 2# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
 3pkgname=loksh
 4pkgver=7.6
 5pkgrel=1
 6pkgdesc="A Linux port of OpenBSD's ksh"
 7url="https://github.com/dimkr/$pkgname"
 8arch="all"
 9license="Public-Domain"
10makedepends="ncurses-dev meson"
11install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
12options="!check" # upstream doesn't have a test suite
13subpackages="$pkgname-doc"
14source="loksh-$pkgver.tar.xz::https://github.com/dimkr/loksh/releases/download/$pkgver/loksh-$pkgver.tar.xz
15	bracketed-paste-mode.patch"
16
17build() {
18	abuild-meson \
19		--prefix=/ \
20		--bindir=/bin \
21		. output
22	meson compile -C output
23}
24
25package() {
26	DESTDIR="$pkgdir" meson install --no-rebuild -C output
27}
28
29sha512sums="
30c03a298e93bff3c689591a9864eeb5daa661b6b0b783102a271f7ebb08297a4939d8c923233fc23892b83c86d7102f9ae022f4b4d3fdf33e095e86690014fb24  loksh-7.6.tar.xz
31c276ad6c6815da3242f955dbe9702d90bdf8c186ce9e57c0945505b3939658c267c14649cdd2fcbabbd4ff9b1cada6dbadf985c94caf263ea2975db8366cbcca  bracketed-paste-mode.patch
32"