aports

Custom Alpine Linux aports

git clone https://git.8pit.net/aports.git

 1# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
 2# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
 3pkgname=mblaze-ui
 4pkgver=0_git20251009
 5_commit=54f778f3d6a87238bb41ffae5a281d36b509413c
 6pkgrel=0
 7pkgdesc="A minimal TUI for the mblaze email client"
 8url="https://github.com/nmeum/mblaze-ui"
 9arch="all"
10license="GPL-3.0-or-later"
11makedepends="go"
12options="!check chmod-clean net"
13source="$pkgname-$pkgver.tar.gz::https://github.com/nmeum/mblaze-ui/archive/$_commit.tar.gz"
14builddir="$srcdir/$pkgname-$_commit"
15
16export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
17export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
18export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
19
20build() {
21	go build -o $pkgname -trimpath
22}
23
24package() {
25	install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
26}
27
28sha512sums="
29a268841fcac1c20b07c93c7c99fea46f856bddc17887450452d45a370864ae578190141eeb85391dbe6deebf8975374ab75b4c4fff0a05c5ac89acdec02414a0  mblaze-ui-0_git20251009.tar.gz
30"