aports

Custom Alpine Linux aports

git clone https://git.8pit.net/aports.git

 1# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
 2# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
 3pkgname=ustatus
 4pkgver=20190721_git20250413
 5_commit=56775fcae87311d296a12411704f2e77bde84ee0
 6pkgrel=0
 7pkgdesc="Minimal status tool for dwm-like status bars"
 8url="https://github.com/nmeum/ustatus"
 9arch="all"
10license="WTFPL"
11makedepends="tinyalsa-dev"
12options="!check" # no test suite
13source="$pkgname-$pkgver.tar.gz::https://github.com/nmeum/ustatus/archive/$_commit.tar.gz
14	config.h"
15builddir="$srcdir/ustatus-$_commit"
16
17prepare() {
18	default_prepare
19	cp "$srcdir"/config.h "$builddir"/config.h
20}
21
22build() {
23	make
24}
25
26package() {
27	install -Dm755 "$builddir"/ustatus \
28		"$pkgdir"/usr/bin/ustatus
29}
30
31sha512sums="
32bffc5ec4d1a7e7e10b9e80a77b5d2eae919190b2755e5e936a1a422cd04ad064f42da14fd7b1a3d91a37c0fe89ee1400aa98f398585bb0257eb39ab90e41794a  ustatus-20190721_git20250413.tar.gz
337a251419f1f835a9e647c4a8d43f89ff572cb3109b55a22e2ec6d45c24fd5fe3d6b6c868ac32e689bd413a2b3ec74e216594e83a7003d756b8e13a6bb6c270a9  config.h
34"