aports

Custom Alpine Linux aports

git clone https://git.8pit.net/aports.git

 1# Contributor: Michał Polański <michal@polanski.me>
 2# Maintainer: Michał Polański <michal@polanski.me>
 3pkgname=wlr-randr
 4pkgver=0.4.1
 5pkgrel=1
 6pkgdesc="Utility to manage outputs of a Wayland compositor"
 7url="https://sr.ht/~emersion/wlr-randr/"
 8license="MIT"
 9arch="all"
10makedepends="meson wayland-dev"
11source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~emersion/wlr-randr/archive/v$pkgver.tar.gz
12	0001-Implement-relative-positioning-options-from-xrandr.patch"
13builddir="$srcdir/$pkgname-v$pkgver"
14options="!check" # no test suite
15
16build() {
17	abuild-meson . output
18	meson compile -C output
19}
20
21package() {
22	DESTDIR="$pkgdir" meson install --no-rebuild -C output
23}
24
25sha512sums="
2642e58b14b1202bcf2d8b8c544d09aa11f1b7ada2b2796006651564c6f839c1e90a2adddf9a868f3858ea1af64cbd003927337fc1be957acdfa29d63c45a54d08  wlr-randr-0.4.1.tar.gz
27f2e3bfb01a04d58485ad2e359a0d7f47540398fd85b5b1f8e675c74d73e73c68dc7a6724c30385cb51dff0926a8da32ae64899f7390f8e02f9cbf87d08bc0b53  0001-Implement-relative-positioning-options-from-xrandr.patch
28"